Registration Authority Customers Unable to Select Country

Incident Report for IEEE Standards Tools

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 15:59 UTC

Investigating

Please be advised the the following affected IEEE SA Applications/Services are currently experiencing issues:

Registration Authority

Customers are unable to complete purchases because they can not select their country,
Posted Jul 16, 2026 - 00:01 UTC
This incident affected: Registration Authority.