IEEE SA Services Experiencing Performance Issues - iMeet Central Public Links
Incident Report for IEEE Standards Tools
Resolved
This issue has been resolved by the vendor.
Posted May 18, 2023 - 19:13 UTC
Investigating
Please be advised the the following affected IEEE SA Applications/Services are currently experiencing performance issues:

iMeet Central - Public file links are not loading properly for unauthenticated users

We have contacted iMeet Central and are awaiting a resolution as soon as possible.
Posted May 18, 2023 - 13:47 UTC
This incident affected: iMeet Central.