IEEE SA Services Unavailable - iMeet Central
Incident Report for IEEE Standards Tools
Resolved
This incident has been resolved.
Posted May 17, 2023 - 12:50 UTC
Investigating
Please be advised the the following affected IEEE SA Applications/Services are currently unavailable.

IMeet Central - displaying SSL error when users try to access.

We are aware of the problem and are working with the vendor to resolve the issue as soon as possible.
Posted May 17, 2023 - 12:43 UTC
This incident affected: iMeet Central.